Dynamic selector not updating with loop

I am trying to have dynamic variable that loops over ID’s by incrementing the ID by 1. However, the get attribute only gets the first ID.

The selector works fine by using static ID variable example: idx=‘3’, idx=‘4’

The ID increases, but the text remains the same. log output:
image

I have tried using the selector as a string variable, but no luck.

image

Hi Mounir,
Thanks for posting your question! In trying to reproduce your scenario, we managed to find some adjacent bugs which we can fix.
We tested the scenario you sent us though, and for 20.10.6 it works for runtime.
Here is what the selector looks like, plus a screenshot with the workflow itself.


There are two mentions which I can make, that might help:

  1. We noticed that your target Selector has an Anchor. Depending on what the anchor is on, that could mess up your selector. Maybe see if removing it helps.
    And 2, with regards to the string selector, it should also work, but make sure that in the Target selector you surround it in curly brackets like this :

{{DynamicText}}

I do hope this helps, and if not, we’ll keep looking into this until we make your workflow works like as should.

Hello,
Thanks for replying,

  1. I’ve tried removing the anchor and running the file in runtime. However, still the same result.

  2. Also, I’ve tried to use the string variable in selector target {{DynamicText}} --> It provide the same output
    image

I think there is an issue that the selector only captures the first ID only without updating(Static). I’ve found a way around it but its not that efficient, by invoking a workflow each time with the ID as an input argument