Dynamic Selector Issues


#1

Hello, I am having difficulty with regard to a “next” selector on a web page. I have looked around for solutions, however haven’t found a precise answer.

I access a web page which uses a series of page numbers and a “next” element/button to progress to the next page:
Only interested in the “next” element. Since the “next” element changes with each page the “next link” selector is unable to click subsequent pages. I’ve tried using asterisks in the selector code with no success.

Does anyone have an xaml file, suggestions or a UIPath pattern which addresses this issue in more depth? The should be a very common problem, but due to my inexperience it has proven to be very time consuming?

Thank you :slight_smile:


UIPATH fails to identify elements on screen
#2

@chasisr23 i tried it on amazon site, and click worked seamlessly. Do you mind sharing your workflow?


#3

Hi
Am facing the same issue. Did you find the answer ?
Please let me know the solution

Thanks,
Aswini


#4

Hi there @aswini_sai,
Can you provide some further detail regarding this issue?

For example, can you share any of the following:

  • The system being used (if it is non-proprietary and freely available)
  • The selector itself
  • What methods you have tried

Thanks in advance,
Joshua Davey


#5

HI Davey…
Thanks for your response

ok…The exception that is troubling me since a long time is that am trying to extract work items from ACME website so Ive used extract structured data activity inorder to extract workitems
even If I use data scraping or activity method i can see the same expressions in the selector , next link selector
I don’t know where am going wrong
Please find me a solution!!!
Any help would be highly appreciated!

Thank you


#6

Hi there @aswini_sai,
Can you provide the full selector being used?

Thanks in advance,
Josh


#9

Hi @aswini_sai,

Can you try aaname as ‘*’.

Regards,
Arivu


#10

Hi Arivu
Thanks for helping me
just now I tried what you said
but I’ve received an new exception

Thanks,
Aswini


#11

Hi @aswini_sai,

It seem like selector issue, try get selector from uiexplorer in uipath.

Regards,
Arivu


#12

I’ve also tried using uipath explorer
but an error is popping out saying "The UIelement is no longer valid "
:frowning:


#13

Use full selector, its seem like partial selector… are you using web application or windows based application.

Regards,
Arivu


#14

Am using a web application…
This exception is from Assignmnt of UI path Advanced certifiation
Where am tryng to extract work items

Regards,
Aswini


#15

Hi there @aswini_sai,
Can you provide the full selector being used, as in the top-level selector of the ‘Attach’ that activities exists within?

Alternatively, can you provide your project and I’ll take a look?

Thanks,
Josh


#16

Even I am getting the same error. Please help.