Drop-down not getting Selected Properly via Select Item Activity

uiautomation
studio
selection

#1

I’m working on a desktop ERP, and I have come across this curious case where when the value is getting selected from the drop-down by the bot, then the value beside it which should get activated on its own isn’t getting activated (Field to enter Advance, First attempt), but the value is activated (turns Red) on its own when I go and select the value from drop-down, and I’m able to enter the value as shown below (Field to enter Advance, second attempt).

problem Recording

Can someone help me with this? Any idea why it’s happening and how can I fix it?

PS: I have already tried changing the value of WaitForReady, but it wasn’t of any use.

Thank you .


#2

Hello there,

Can’t say much but how about give some delay before/after.

Workaround: As drop-down contains only two field and if the order of the values (fixed and percentage ) remains same then you could try with SendHotKeys.


#3

@ddpadil thank you for the reply. I tried giving delay but they don’t seem to work. Giving delay before the activity makes the select unusable for some reason. I’m traversing the fields via tab (not with selectors or anchors)… the given form doesn’t have reliable selectors to use click or any selector based activity.

Is there any other way via which I can select the elements of drop down?

Thank you .


#4

How about image Automation.(use CITRIX WIZARD)
adding to above point ,something like this.


How to enter text in citrix environement
#5

@ddpadil hey, I have been using the same technique. Apparently, it’s not helping with the drop-down fields.Correct value is getting selected , but somehow the related fields aren’t getting activated.


#6

means advance label not getting activated (red) ?


#7

Yes. when the bot selects the “fixed” value from drop-down then it remains deactivated. But when I go ahead and select the same “fixed” value then it gets activated (turns red).


#8

Looks like its’ on the focus .
if its sendhotkey then tweak “ClickBeforeTypying" ,EmptyField"SendWindowsMessages” properties.(I know none of makes sense :stuck_out_tongue: but give a try.)

PS: Do you mind trying twice(make bot to select twice)? does it work then? just want to understand where is the issue.


#9

I had this issue using Selet Item with Cascading drop downs in a windows app. I think I resolved it using Click on Dropdown and Type Into. Not sure if you already tried this, just an idea.


#10

I solved the issue guys. Used select item and then used the type into (For some reason normal Type into wasn’t working directly on it). Type into with filed name made sure the correct values are “entred” and selected.

Thank you, guys :slight_smile:


#11

please follow below tutorials on drop down,