Downloadfiles activity: {clr-namespace:DownloadFile;assembly=Download File}

Hi guys, I have developed a process using @studio 2021 that involves downloading files from web using DownloadFiles @Activities. When I publish to the @Orchestrator 2019 it takes too long and after finishing and running the job process I get the error below.

System exception.Cannot create unknown type '{clr-namespace:DownloadFile;assembly=Download File}DownloadFile'.

But Same process if I run it on my development environment through studio 2021 it works fine.

Hi,

It is because the package does not exist. So maybe your code cannot run under Orchestrator 2019 because this activity needs recent Orchestrator.

Hi @wilbardmtei ,

You can upload this package to Orchestrator shown below.

Hi @melanie, basically this process queries the database and get file URL for downloads. So when I take invoked workflow and turn it into process so that it only download one file, works fine. So I’m not able to understand why the whole code should not run.

Hi @ermanoj3101 I tried your method and it is taking too long to install the process. I have checked on the forum seems it is taking long to install because of the libraries and being downloaded from market place.

Kindly assist on your views if you have had this issue.

Not sure but in my case i have only one library that was not present so it worked for me at that time.

Maybe someone else had face this issue, just wait for some more comments.

Thanks