Download file activity picking .tmp file issue

Thank you @loginerror for working on this fix.
Thank you @ptrobot for the workaround workflow for this issue.

1 Like

Waiting for this fix

2 Likes

I got same error while downloading Zip file , it showed cannot find file at “downloadpath\somename.tmp”

4 Likes

I’m currently facing this issue, I tried the workaround mentioned above but that did not work for me as the file name never changes from *.TMP! Please someone help

Hi @Ali_AF

This might not be a full proof workaround, but if you can extract the URL of the file you want to download, you may try the HTTP Request from the WebAPI activity package to download it by making a GET request and saving your file via the ResourcePath property:
image

Is there a work around for studio x?

Is there still no solution for this? maybe UiPath should remove this activity if it is technically too sophisticated to download a file from the internet…

Hi @Frei_Janick

We are investigating the issue and a fix is currently scheduled later this year.

Yes just write your own While loop that looks for the file and doesn’t exit until it finds it.

Does this mean current UiPath “Wait for download” activity could get “tmp” file in some situations and there’s no way we can avoid it(wait till “tmp” turns into a real file, then get it) until the fix is made later this year?

Appreciate if you could give any advise on workaround.
Thank you for your support!

@kotaro.hirano I am attaching the workflow for the workaround to download the file. Let me know if that worked for you.
DownloadFile.xaml (9.3 KB)

1 Like

Small update. Next release should include further improvements to this activity.