dotNet Application XTPToolbar -> how to click items

Hello,

until a few days ago we had a process that worked with a dotnet application.
We already had difficulties with the creation of the menu items. The first menu items could be reached without any problems and the activity (e.g. Click) showed a green menu item “validate”. Sub-items could also be found, but showed a red menu item “validate”. Nevertheless, it worked perfectly during the run. But now there seems to have been an update in the program and I can only find the menu ribbon in the UiExplorer but no individual menu items.
grafik

Does anybody here know a solution how to work with this menubar/ribbon? Any hint can be useful.
Thanks in advance.

Kind regards
Martin

Hello @martinN!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

Hello,
now we found that the behavior described occurred after a Windows update to 1903. Although I don’t have a verified solution yet, we will try what is described here: https://docs.uipath.com/studio/v2019/docs/identifying-ui-elements-after-windows-updates. If this is the solution I’ll will let you know.
Edit 04.09.2020: Yes, that is the solution! Yes, in our case it was KB 4571694 that affected our system. after re-registering the oleacc.dll and importing the mentioned keys from a system that was still working, we were able to restore the correct state.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.