Dot character

uiautomation
studio

#1

Hello,
I’m automatizating the creation of users in MS Active Directory connecting via RDP to the domain controller.

When I enter the email which would be name.surname@xxx.xxx with a “Type into” Activity the dots get lost I guess because the dot is a special character.

As “Type Into” text I tried:
name+"."+surname+"@xxx.xxx"
name+"."+surname+"@xxx.xxx"
name+chr(46)+surname+"@xxx.xxx"

but nothing works and I get always: JohnDeer@xxxxxx
supposing having:
name which is a string ="John"
surname which is a string = “Deer”

Typing the dot character manually into the Active Directory windows works fine.

Could anyone help?

Thanks


#2

Hi,

Have you tried using & instead of + to concatenate?
What about trying “.”.ToString or “.”.ToCharArray?
Maybe also try using SendWindowsMessage or SimulateType property.

I have never seen this issue, so I’m not sure I can help that much. But, you could also research vb.net online for potential other solutions.

Regards.


#3

Thank you for the reply. Unfortunately no success in doing what suggested. I guess the dot is a special character. I tried with “.” but no luck as well.
I tried also to type into a notepad.exe running of the server I connect to via RDP with no success i.e. the dot is not recieved.

Any other idea?

Thanks


#4

Hi All,
we solved the issue using the following workaround:
“Set to Clipboard activity” with “.” as text + Send Hotkey with “Ctrl + V”

We were told that it might be related to the Keyboard Layout not set to English (US), but we havenì’t test this solution since not feasible for us.

Cheers