Don't have Permissions to Open a File

I am trying to do the Building a Workflow Part 3 training. I have been able to get the bot to work for parts 1 and 2. When it is trying to attach the invoices to the email, I get the message below. I have tried moving it to my desktop, a download folder, on the computer and my one drive. This is a work laptop. Any advice would be helpful.

“Excel Application Scope for each invoice sheet: Failed opening the Excel file . Possible reasons: the file is corrupt, the file is already used by another process or you don’t have permissions to open the file.”

Hi @Lesniczak_Kelly,

There can be many reasons, my suggestion would be to end Excel process from Task Manager. Also, make sure the file is not opening in read-only mode.



Can you share the screenshot of the workflow? The place where you are getting this error.

This is the message I’m getting now:

Are you using it inside excel application scope? or have you used excel application scope for that file previously?

That was it. I moved it out and retested and it worked. Thank you! I’ll remember to do that going forward.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.