Does the 'get outlook emails' activity not get attachments in community edition

i am trying to get the attachments in an email but its coming back as null even though i do have attachments in there.
in the locals its says my email has attachments(0).

Hi @Rowley101

May I know which activity you are using?

and is it an attachment or is it any image pasted in the email?


when UiPath.Mail.Acitvities is not upgraded to the latest version then upgrade it and test again.

i am using the most recent one. still get same error

‘Get outlook emails’ to get mailmessage collection
‘for each mail in mailcollection’
‘Assign’ attachments = mail.attachments
‘for each attachment in attachments’
‘write line’

we had something similar encountered in the past (that’s why we asked for the version)


As suggested in other post can you check if you save directly if you are able to see the attachment?

and alternately can you check the same by using outlook scope activities

And I hope you did not paste the attachment as an image in the mail but is actually attached


tried to save attachment first but it doesn’t show in the folder destination

Hi @Rowley101

Can you use a log message and confirm if the correct email is getting retrieved?

Try with version 1.15.2 which was the previous stable version