Document Understanding not working in VM


When i run a process in local which involve Load Taxonomy, Digitize Doc, Classify Doc, Data Extraction scope, Export Extraction Result, all works fine and able to get output as expected.

However once i tested in VM, bot only runs until Load Taxonomy and does not proceed to next one, as if it’s skipping the following sequence. Tried to log info also and no output starting from digitize doc.

Pls advice. Thanks


Can you provide more details…like is anything failing?

Or its stuck?


its not failing, it just skips the sequence after Load Taxonomy and do the activity after Export Extraction Result.

And i say skip is because i put a log between all the process starting from Load Taxonomy until Export Extraction Result, but its only showing the log after Load Taxonomy.

Hi @syezids ,

Could you maybe let us know how the implementation was done ?

Maybe a Screenshot of the workflow ? Is there a Try Catch in place ? Is it set for all of the activities and maybe no Logs are provided in the Catch part ?

hi @Anil_G and @supermanPunch ,

this is the error i got:
One or more errors occurred. (Error performing OCR: Unable to load DLL ‘recdiag.dll’ or one of its dependencies: The specified module could not be found. (0x8007007E) OmniPageErrorLoadEngine)

it was working in local, but has this error in vm.

Hi @syezids ,

Could you maybe check in the VM’s connected Orchestrator if the OmniPage OCR nuget packages are present ?

If not could you add them and check?

i changed from omnipage to UiPath engine and it worked, not sure why.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.