Do I need a license for the Robot of Studio Community Edition?

Hey everyone, I had installed some versions of UiPath, through both Platform Installer and Community Installer. Recently, I’ve uninstalled them all and installed Studio Community Edition 19.10.1 and tried to run the robot through the command line (UiRobot.exe -file [mainXamlFileAddress]) but in return I got the following error. Please note that I activated Studio with the free edition:

A local license is required.

And here’s the output from Regutil.exe get-info:

Error #17: Cannot read license code: -1094, error description: NSL not licensed
License status: -1
Device id: VRWwixprf+IYLtdJDMma
Error #20: Cannot read license expire date: -6003, error description: Lookup of tag failed
Maintenance expire date: not set
Subscription expire date: not set
User defined field "Attended": not defined
User defined field "Unattended": not defined
User defined field "Free": not defined
User defined field "Dev": not defined
User defined field "AttendedConcurrent": not defined
User defined field "DevConcurrent": not defined

I have 19.10.1 Studio on my other machine and the UiRobot.exe command works fine on that. What shall I do?


Please connect this machine with cloud Orchestrator and acquire license from it.
1 Like

For my other machine I did not do that and it works OK. I did not install Robot from the Platform Installer. That was installed alongside with the Studio Community version. In that case, why shall I activate the Robot itself from the Orchestrator?

@Forum_Staff help please.

Hi @atoi,
Please uninstall Studio and then remove all data from %userprofile%\AppData\Local\ and %userprofile%\.nuget\packages
Finally try to install it again by downloading Community Edition from

1 Like

Thanks a lot @Pablito, problem solved. Just one thing, now that it’s solved, it came to my attention that when I try to run that through the Windows admin credential it throws that message again. Why’s that? Is it like every instance of the license or Studio valid for the user that has installed it?

Exactly as you said. In case of Community Edition it’s installing per user thread.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.