Disable SaveAs dialog box from appearing inside VDI


Is there a setting inside a VDI machine that we can configure to disable SaveAs Dialog box when downloading from Google Chrome?

“Ask where to save each file before downloading” option in Chrome was already disabled, but still pop-up is showing (See screenshot below).

Thank you in advance :slight_smile:

Welcome to the Community Forums @Igan_Roperos

Usually if browser settings are set by company policy you need to adjust automation to work with it respectively to your companys policy. Is the option reseting itself everytime you re-open the browser or re-boot the machine?

Maybe a work-around is to use “private” mode in Browser - but I believe the policy will be set the same in there.

Hello @Igan_Roperos
I am not sure about the issue. You can detect the save as pop by using element’s exist activity and indicating the Save as pop and typing the file name with downloading path using Typeinto activity.

Thanks for your responses. @iamNairda @Gokul_Jayakumar
Though as much as possible we wanted to avoid updating the code, and just handle it by configuring the settings inside VDI. Additional note is that, even when using incognito mode and disabling the SaveAs dialog box pop-up setting in Chrome(as seen in the screenshot above), it is still appearing.

If you do not wish to change anything in UiPath Studio (like @Gokul_Jayakumar) mentioned, then I think you’re only alternative is to speak to your IT department about the problem. To me it seems like a policy problem, to further evaluate this you can test if it’s the same for other Browsers (Edge might be installed already) with the popup always appearing.