Different Behavior Encountered Manually vs Bot in L3 Assignment 2

This is my 2nd round of doing the A2 for practice before my practical exam and have once again found different behavior in unit testing and integration. I get the results I expect when unit testing in the Create Reports xaml where I am downloading each month. I get “No report exists” when I run the bot full speed, but when I do it manually the Save dialog comes up with a report? It’s clearly understanding I clicked on “Download” or the dialog wouldn’t come up. So it is a different response. This makes no sense.

Hi AlienV

First of all which browse are you using?, If you are using IE 11 you must Enable the File Download prompt.

Please note that when you click download, a save as popup will appear which will allow you to save the report and merge in the yearly report then delete that month’s report until December whereby you will be having a yearly report that you will upload and then update that the report was completed

I understand the process, I don’t understand why it works in unit testing but says no reports exist when running in full speed. I’ve built this before. I’m using IE. It should work exactly the same. The dialog box says no report exists when it is done manually.

Update: Rebooted the computer and it started working properly.

Note to the frustrated

UIPath undocumented behavior: (pertains at least to Academy Assignment)
After continuous repeated testing UIPath does not work consistently on the System1 website.

  1. The workflow might work in Debug mode but the Run mode may not if you have not rebooted after some time. This is not always speed issue as many would think. I did.

  2. The browser will eventually slow to a snail’s pace on repetitive testing unless the WAIT FOR READY command is changed on click and type activities. I’ve built this twice its consistent.

  3. Relogin to the System1 while Unit Testing as you think you have a connection but you wont be getting any reports on download when doing the Create Yearly Reports. It is because you are actually DISCONNECTED!

There are still inconsistencies. If nothing works come back the next day and it might! It’s happened to me after continual repetitive testing. I’m not sure what to reset in browser (e.g. cache, etc.) to get it right.

Does anybody have resolutions to this better than a reboot or more exhaustive?

1 Like


I experienced this behaviour last night. Very annoying.

I am facing the same issue. When I run the CreateYearlyReport.xaml only it downloads the Monthly Reports as expected.
But when I Run the Performer Workflow it always shows No Report Found pop up for all the months for a TaxID, however when i manually tried for the same TaxID and Month, the report was downloaded.

Please note that I have tried and cross-verified the below mentioned steps, but it is not working for me:

  1. Rebooted the Laptop.
  2. Using IE 11 and pop up for Downloading is enabled.
  3. Orchestrator Service is enabled.
  4. Robot is connected and Licensed.

I am really not understanding why it works when the xaml s run individually, but doesn’t work when the workflow is run,

Please Help me out, I have almost completed Assignment 2, but stuck at this step.