Desktop outlook app error

“Use Desktop Outlook App” activity and inside “Send Email” activity. When “Save as draft” is checked no account is selected in Outlook (it just states “Outlook” and manually I have to select the account). When “Save as draft” is not selected I get the error System.Runtime.InteropServices.COMException. So for some reason the choosen account in the dropdown from “Use Desktop Outlook App” activity is not working. I have tried searching the Forum for solutions but nothing works. I do not understand that I can choose the correct account from the dropdown but then it gives the error.
Any help would be very much appreciated.
I am the administrator and have tried to change UAC, programmatic access etc. but with no luck

1 Like


Try with these steps

  1. Close your outlook application if opened
    Restart your studio also and give a try

  2. If that doesn’t work, then I’m studio go to Design Tab → Manage Packages → Project Dependencies-> search for UiPath.Mail.Activities
    Uninstall it even if it’s latest package and reinstall again the latest package and then give a try after restarting studio

  3. Finally get through this knowledge base from UiPath and try with the resolution mentioned here

Cheers @raven


  1. Is the outlook licensed?
  2. And are you able to see your account in the drop down at all?
  3. Can you try once with send outlook mail message activity and see if you are able to connect


None of the suggestions helped - I will comment as following:

  • Restarting/closing
  • Unistalling packages
  • Outlook has not been downgraded and there are no other versions than 9.6
  • Outlook is licenced
  • Yes I am able to see all my accounts in the dropdown
  • The e-mail is created if I save as draft, but with no account

I really need help here because I am stuck