Desktop has been disconnected


#1

Hi,

I am having some trouble with a workflow, that sometimes fail with the message: “Desktop has been disconnected while performing UI actions”. The robot is running on a physical PC, and is accessed via TeamViewer. It often happens when logging into a specific system, but also at other parts of the workflow, so somewhat random. Does anyone know how to fix this? :slight_smile:


#2

Hi cec

Do you have any studio logs or event viewer logs?


#3

This is the error message showing up in the exceution logs. Is this what you meant? :slight_smile:

14:05:58.5848 Trace {“message”:“Exception thrown: UiPath.Core.ElementOperationException: Desktop has been disconnected while performing UI actions. —> System.Runtime.InteropServices.COMException: Desktop has been disconnected while performing UI actions.\r\n at UiPath.UiNodeClass.Click(Int32 dx, Int32 dy, UiClickType clickType, UiMouseButton mouseBtn, UiInputMethod inputMethod)\r\n at UiPath.Core.UiElement.Click(Int32 offsetX, Int32 offsetY, ClickType clickType, MouseButton mouseButton, InputMethod inputMethod, Position mousePlacement)\r\n — End of inner exception stack trace —\r\n at UiPath.Core.Activities.InvokeWorkflowFile.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)\r\n at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)\r\n at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)”,“timeStamp”:“2017-01-25T14:05:58.5838189+01:00”,“level”:“Verbose”,“windowsIdentity”:“norobotic”,“processName”:“Process”,“fileName”:“main”}


#4

Please run the same workflow without team viewer, using windows RDP to connect to the test machine and let us know if this still reproduces.


#5

I tried running the workflow from the physical PC, without anyone accessing it through teamviewer. The same error still occurs.


#6

some workflows have issues when the user uses team viewer to connect to the test machines, this is why i`ve asked you to try. we need to investigate further, can you give us more logs?

clean everything from C:\Users\ youruser \AppData\Local\UiPath\Logs and from event viewer->windows logs->application and reproduce this issue. then upload them here and we will investigate.


#7

The only other messages in the UiPath logs are custom log messages from the workflow to detail which step the workflow is on (unable to upload them here, beceause they contain client information).

In the application log, while the robot was running there were many instances of the following two error messages:

Source: MSSQL, EventID: 1827, Task Category: Server: “CREATE DATABASE or ALTER DATABASE failed because the resulting cumulative database size would exceed your licensed limit of xxx per database”.

Source: MSSQL, EventID: 1105, Task Category: Server: "Could not allocate space for object ‘LG.DALogEntry’.‘PK_DALogEntry’ in database ‘DA4LOG’ because the ‘PRIMARY’ filegroup is full. Create disk space, … "


#8

does your workflow have database activities in it?

the “disconnect” error you are seeing is related to some issues and limitation the RDP tools like team viewer or default windows remote app have while running workflows connected to the machine through them. so its hard to understand why it did reproduce while connected directly to the test machine


#9

Not directly, but it is creating client files in a document management system, and transferring files from an older document management system, which uses the database.

We have two other physical PCs that are running the same workflow, which are also accessed through teamviewer, and they do not have this issue. Robots have been running for the last 7 months or so (have been using teamviewer to access them), and this is the first time we have seen this disconnect error :slight_smile: