"Desktop has been disconnected while performing UI actions."


#1

Dear all,

I always faced “Desktop has been disconnected while performing UI actions.” in live environment.
But same sequence is well done in other test environment always.
The sequence is made by Desktop recording.
The difference is only that many user use same application to automate in live environment.

OS is same in live and test environment; windows 7 professional x64.

What is cause of the error?

I referred the following link, but cannot explain why the error happens in live environment only.

I use community edition and cannot use Schedule Task now.

Execution log is below;
11:56:50.0075 Info {“message”:“170510_Test_miy_02 execution started”,“level”:“Information”,“timeStamp”:“2017-05-10T11:56:49.986579+09:00”,“windowsIdentity”:“GRC-015\バーダック”,“processName”:“170510_Test_miy_02”,“processVersion”:“2017.1.6339.21370”,“fileName”:“Main”,“jobId”:“23ed559f-8b9c-4467-b593-598b4a8cfa13”,“robotName”:“バーダック”}
11:57:20.5863 Error {“message”:“Click ‘menu item 編集(E)’ : Desktop has been disconnected while performing UI actions.”,“level”:“Error”,“timeStamp”:“2017-05-10T11:57:20.5863292+09:00”,“windowsIdentity”:“GRC-015\バーダック”,“processName”:“170510_Test_miy_02”,“processVersion”:“2017.1.6339.21370”,“fileName”:“Main”,“jobId”:“23ed559f-8b9c-4467-b593-598b4a8cfa13”,“robotName”:“バーダック”}
11:57:20.6013 Info {“message”:“170510_Test_miy_02 execution ended”,“level”:“Information”,“timeStamp”:“2017-05-10T11:57:20.5973298+09:00”,“windowsIdentity”:“GRC-015\バーダック”,“processName”:“170510_Test_miy_02”,“processVersion”:“2017.1.6339.21370”,“fileName”:“Main”,“jobId”:“23ed559f-8b9c-4467-b593-598b4a8cfa13”,“robotName”:“バーダック”,“totalExecutionTimeInSeconds”:30,“totalExecutionTime”:“00:00:30”}

Soshi


"Desktop has been disconnected while performing UI action" error while running Lesson 2 Practice 1
#2

Dear all,

How UiPath distinguish the process?

The PC has several users and the users log in with remote desktop and use a same application at same time.

I install UiPath in the PC to which several users access with remote desktop and tried automation the application with desktop recording by local user.

Is this possible?

Regareds,
Soshi


#3

HI, I met the same problem, have you solved this problem now?