Desktop application: No detection of logical elements within a desktop application

Hi Community,

I have always believed that for all desktop applications it is possible to use data scrapping and not screen scraping, meaning that within UIPath you can chose the logical elements (e.g. fields) within the application for scraping or filling data. In my first sample I exported data from an excel to an address management system via RPA on Windows 7. I recognized that I could only scrap the whole application window but no logical elements within the elements. For other software application this has worked, so this is not a general problem in my configuration.

Do you know any reasons or limitations why UIPath sometimes does not recognize the meta data of an application ?

I am not speaking of citrix published application.

Best regards,

Dennis Suhari

Hi @dsuhari,
Can you check your Open Browser activity by navigating to a sample webpage?
Check whether you are getting “Cannot communicate with Internet Explorer” error.
DLL errors, such as those associated with oleacc.dll, most often occur during computer startup, program startup, or while trying to use a specific function in your program.
Let me know.

Hi @jibanjyoti,

the mentioned application is not a web application, but a desktop application. I don’t really get why I should check open browser activity. Nevertheless communication with my internet explorer works fine within the open browser activity.
Can’t see in which programming language it was written, but only see DLL (which could be C#, C+ etc.).

Are there any application or application genres (e.g. certain application frameworks) that are not supported ? As already said my application is a simple address management tool.



Just to ensure that you dont have dll related issues i told to check.


I have found out now, that the mentioned application was written in Delphi.

Any experience that UIPath has problems with detecting Delphi applications ?



I haven’t actually tried it yet, but UiPath does say that it is compatible with Delphi, there is a topic along a similar thread here. They also list it on the website.

I am auotomating Desktop application,i want to scrape table but webscraipng is not working/detecting the table.i am unable to get the data from table(I need all data which is in table)
May I know how can we scrape or gent entire data from data table.

Thanks in advance…

does data scraping not work?

Hello friend, did you get uipath to recognize Delphi?

I’m trying to use with Delphi 7, but it does not recognize.

Thank you

did you manage to solve this problem with Delphi?

Did You manage to find the solution for this tabel?