DeserializeXml error while running UiRobot.exe, works OK with UiStudio


I have installed and I am running UiPath Beta 18.2.0 Beta.

In one of projects, I call a workflow where Im using DeserializeXml activity, to process a xml config file. This works without issues when running inside UiStudio, but when I try to run it from command line with UiRobot, it fails with:

System.Xaml.XamlObjectWriterException: Cannot create unknown type ‘{}DeserializeXml’.
at UiPath.Core.Activities.InvokeWorkflowFile.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I have tried uninstalling/re installing UiPath, uninstalling and reinstalling different versions of Activities packages, publishing the projects, etc. but the output is always the same

Currently I have these installed, but as I wrote above I have tried with older versions too:

18.2.6711.13657 Core
1.1.6667.25334-alpha Credentials
2.4.6712.16526-alpha Excel
1.0.5905.30080 Framework
1.0.5905.30080 Mail
2.1.6080.24985 Platform
1.0.6710.16240 Scripts
7.0.5715.29283 V7.Activities
1.1.6712.16531-alpha Web

My beta version right now is 159.

Has anyone experienced something similar? Looks like the robot is not recognizing some package.

Thanks, regards

I am thinking that the API from cmd requieres admin access-- do you have that level of access–?


Hi beesheep,
yes, I think so. I forgot to add that I can run other processes with the robot, without issues. It seems its the specific use of DeserializeXml that’s not working.


Hi @nspedalieri
Try to publish and run robot.exe.
I think this issue is a bug 2018.2.x

I’m facing similar issue. After updating to 2018.2.3 the robots won’t run unattended because of error
Error {“message”:"Launch Workflow Interactive: UiPath.Core.Activities : Cannot create unknown type ‘{}Variable({}DatabaseConnection)’

I tried uninstalling/re-installing all activity packs but it didn’t help. Should I rollback to version 2018.1.x ?