Deploying robot from community to enterprise

Community version: 2019.4.2
Enterprise version: 2019.4.4
Orchestrator: No

As we are starting migration from community uirobot runtime to enterprise runtime, I’m having problem during my testing on deployment of .nupkg made from uipath studio community edition (dev environment) to uipath runtime enterprise edition (test environment).
See steps I did below:

  1. Create robot and Publish nupkg from Computer_1 - Community Edition
  2. Paste .Nupkg on Computer_2 - Enterprise Edition
  3. Download .nupkf in UiRobot in Computer_2

Problem/s encountered:
-Downloading nupkg takes time
-When I run the robot, it states that it is running but not doing anything. (even simple message box do not run)

RCA:

  • XAMLs in …nuget\packages\version*.xamls do not have permission also under the current user loggedin. (no read/write)

  • I tried to create and publish robot from the enterprise edition on the same computer, the download/running in UiRobot is smooth and working. XAMLs in …nuget\packages\version*.xamls do not have permissions also under the current user loggedin.

Is this some licensing issue or not possible? Seems publishing the robot via studio works.

Thank you!