Deploy Process --> no environment selected + Robot Can't See Process in Modern Folder

I am trying to deploy a process in Orchestrator. I created a “Service”, then published a package to orchestrator. Then I went to create a Process. When I’m in the Default folder (classic folder), it requires Environment to be entered, but will not accept anything I type in the box.

Because I can’t select an environment, the Create button remains grayed out.

Interestingly, I can create this process in a “modern folder” that I added because the dialog for Deploy Process does not include Environment on “modern folders”; however, the Process I created in the “modern folder” is not visible in a UIPath Robot connected to this Orchestrator.

Some questions:

  1. What “Environment” name is the Deploy Process looking for?
  2. Where do I find “Environment” names?
  3. Is an “Environment” the same as an “Organization” or “Instance”? A “Service” or “Tenant”? There seem to be some nomenclature changes between the existing documentation and the way the product currently works. Any help you can provide with this topic will be greatly appreciated.
  4. What do I have to do to the Process in the “modern folder” to let a Robot see the process and execute it (I enabled all the permissions I could find, but still no visibility.)

modern folder can only see attended stuff for now… environments are groups of robots, organizations is more related to the users…

Thanks for the quick reply!

My Robot is attended.

How do you get “UIPath Robot” running on a local machine to “see” a different Folder than “Default”?

Okay–I answered part of my own question. I figured out how to add an Environment under Management/Robots while in the Default “Classic Folder”. I was then able to create my process in Processes/Deploy Process using that Environment.

But…

My local machine still does not “see” any Processes. I think it’s because the UI Robot program on my local machine runs as me \Bill.Richardson and connects up to the cloud Orchestrator that way also. The Robot in Orchestrator is associated with my machine and username. How do I give “\Bill.Richardson” permission to run the contents of folders? There seems to be no way to add user “\Bill.Richardson” under users so I can do this. I tried “invite” but my email is different than my domain\user combination so it just creates an unrelated user.

So if anyone knows how to create the user that matches my domain\user, I’d love to hear about it. Thanks!

Ok–more poking around, and I got my local UIRobot to connect as a user and at least see the Default (Classic) Folder.

If anyone else is trying to do this and was confused by how it works–here was the solution:

After creating an Environment (so I could Deploy in classic folders), I had to go back to Environments and check the box for the robot to tie it to the environment.


image

Only question that now remains is how to get Attended robots connected from a local machine UIPath Robot to see “modern folders”. If anyone has information about this, I’d love to hear about it.

Is this issue resolved or a bug in Orchestrator cloud? I also cannot add/modify environment for Classic folder?