Demo Queues Module Orchestrator Foundation [2020.10]

Not sure if it is a bug or the instructions presented in video Queus Module (13) Orchestrator are out of sync with current status of Orchestrator, it is not possible to ‘Create (start) the job’. Please follow screenshots below, they are pretty self explaining
Setting up dispatcher Successful : Excel fetched items listed in Orchestrator > Queus

Using Performer > Automations > Jobs > Create Job > ! Problem !

As instructed, leave (select) ‘Account (‘user’?)’ and ‘Machine’ > both ‘Any’. However checking both icons, both ‘User’ can be found on which Roles can be assigned and [default] cloud robots -serverless seems to be assigned as Machine.

It is NOT possible to [Create] the job due to the fact ‘No runtimes Type’ is available. I gamble I should be able to select ‘Unattended’, but I’m not sure!

Can’t select anything can’t create (start) the job !

…continuing with Triggers, I faced the following hurdle which seems pretty directly related to the one just mentioned, apparently I have missed something about

setting or creating a ‘non-productive runtype’


For using unattended type…you need to create amachine and assign unattended licenses to the machine

And also you need to assign robot role to a user as well to run unattended



Please validate these two things before executing:

  1. Check f license has been allocated, refer below screenshot:

  2. Also make sure: Unattended settings are in place, refer below screenshot:


Thanks for your suggestion! Apparently I had a misconfigured machine template.

Solved this underlying problem, actual took an U-turn, removed pending Jobs on that Machine Template turned out to create a new Machine Temlate, went back to the Job configuration…
…moving away from the page (what I call: the ‘working folder’ - Machines-Tab (sub page)) > going back to [Automations]-tab > seeing the process on which I want to add a Job (this means selecting that process) on the table row (not the main Tab as sub choice below Automations)

…coming back on > ‘Working folder’ > Automations > Processes > Selecting the Process TableRow on which to start a Job > I was surprised tweaking the Job still NOT able to select the Runtime type being in ‘pristine state’ clicking it 1) still not able to select one, immidiately change to ‘faulty’, and in conjunction as expected a [Start]-button not available
…the only choice to make hitting [Cancel]…
… surprised, after hitting [Cancel] being redirected to the Machines-page…

…best choice > Automations > Processes > Selecting the Process TableRow on which to start a Job > Start Job > …
…now the run-type box is pre-filled with Production (Unattended) Phrase and other labels, one selectable, several not (selected > Testing)…
…[Start]-button > enabled…
…choosing ‘Testing’ from Runtime-type selection-list…

stuck again !
…one change left > selecting predefined option ‘Production (unattended)’

Conclusiont still NOT able to create a Job

Under Icon Account (which is default ‘Any’) I am able to find my own account and asign roles on it, coming back on ‘Create Job’-dialog > The account box does NOT change ‘Any’ stays the predefined choice

Still not sure if this a process bug or lack of knowlegde


As per error…we can see that in ypur machine whoch you assigned to the folder you did ot provide credentials…edit the machine and then provide the credentials there


@Anil_G you’re telling me, in the first part of your response…
‘we can see that in your machine which you assigned to the folder’
which means to me, on an Edit-dialog of the machine I should be able to couple credentials thru selection, typing-into, e.g.,
a) coming from Tenant level > Machines > Edit Machine dialog


b) coming from ‘working folder’ > Machines > Edit Machine dialog

…arriving at…

…there is on the Edit-dialog of the Machine NO option to provide credentials

What exactly do you mean?
On which screen did you (and others çause you’re writing ‘we’) see something I apparently miss?

…you aren’t talk about Assets, do you? To me an ‘Asset (Credentials)’ does have a completely other ‘purpose/use/meaning’ doe something else …

…this is weird!

Going back to Start Job dialog (via ‘Working Folder’ > Processes)…
…there is the option to select ‘Account’ default stated: ‘Any’…
…as I did before, I hit the ‘Account’ icon…
…on that Account dialog able to find myself, on a previous try-out selected Automation Users als Role…
…now I selected all options of provided Roles, Saved and came back on the Start Job-dialog…
…on previous tryouts, I was not able to select anything else in that Account box as ‘Any’!
!Now, suddenly I am able to select myself…
…now, and now (finally) I do see something which might may look like, you’re are trying to tell me…

…reaching, this stage (select this dedicated account) it turned out not able to create the Job, however clicking away this acount, having an ‘Any’ account again…
…[Start] became Enabled agina, hit it, and…
…actually expecting a warning about misconfiguration (as I had before)…
…surpringly not! The Job has been created!

In this tweak process being logged-off (session expired on Orchestrator Cloud e.g.) several times… …do I get it ‘how’ I finally succeed? Actually not (questions left)…

You are an inside person on UiPath, are you? Anyway, thanks for response!


Sry please go to manage aces. pge where you will see it once you click next

Navigation at top for you


@Anil_G thanks for support!

1 Like


Hope this cleared your issue



…I’ll be honest, not at this level, no!

Although, I’m finally be able to create Jobs, they stay ‘pending’, can’t do anything with them, don’t see any activity of a process or whatsoever… …something else still wrong I guess ?!?

…to me still too much trial-error and hazy relationships between different entities, e.g. oh well…
…I continue…
…try to be happy (as always)…
…the sun did rise on this beautifull sunday morning, hopefully tomorrow as well !


There is no trail here…but a specific process to follow

When runnin gfrom orchestrator you need a user with robot role and credentials to be procided

A machine with unattended license

Then connect the vm or laptop with that and make sure it is available