Debug the file does not stop at the breakpoints but executes the whole file


In the new version (21.10), I can’t debug the file. It’s not stopping at the breakpoints but executing the whole file.

@kumar.varun2 are you using non-ascii chars in your project path? We have a known issue for 21.10 and the workaround is to create the project in a folder with friendly chars (like C:/MyProjects).

We fixed this on our side and we will release a new version later this week.

I am using ASCII characters only.

Can you DM me the project where the issue replicates?


It is not stopping if the breakpoint is applied on ‘comment’ activity. If any other activity is made the breakpoint then it works. But in previous versions if the breakpoint is applied on ‘comment’ it used to work.

Could you maybe post a screenshot of the breakpoint?

I’ve tried to reproduce it and Studio 2021.10 is actually forbidding me from setting a breakpoint on top of the Comment Out activity:
(it simply doesn’t do anything)

My package versions for reference (System being the important one):

Hi @loginerror @alexandru

It is not the ‘Comment Out’ activity but ‘Comment’ Activity. Please refer the screenshot

I have already DM the project files to @alexandru

Thanks, I managed to reproduce it.

I pushed this topic to our internal bug tracker for out team to have a look. We’ll keep you up to date :slight_smile:


@loginerror Even in the new version 21.10.2, the bug is still there.


Still not resolved in the latest version 21.10.3

This is correct, the issue is being worked on and a fix is scheduled in future versions. I’ll update this topic when the fix gets included in one of these future releases.

I faced this issue twice with modern design and Repository. I resolved it by unlinking each modern activity from repository and reuse it.


Hi @bruno40,

If you are facing this issue in the new versions, @loginerror, @Pablito can help on this.


Thanks !
I’m using Studio 2021.10.5.
It is resolved now.

It is ignoring Breakpoint on comment activities

We can confirm for:

  • Studio 2021.10.5
  • UiPath.System.Activities 21.10.4

I can see that this should be fixed in 2022.4 :slight_smile:

Thanks for fixing the bug


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.