Date-Picker ACME system 3

There is a date picker in ACME system 3. I try to click on down arrow and the select one of the date using UI explorer but it throws an error “Ui element doe’snt exist”. Can anyone please help me with this.


Have you tried using ‘Type Into’ on the field itself instead and typing the date in directly?

I’d strongly recommend avoiding actually automating a calendar control unless you are forced to. It involves much more complex actions and dynamic selectors in order to get the correct month and year you want before even selecting the day.

The simpler solution is often the most stable.

1 Like

To add to this, if Type Into doesn’t work you can also try Set Text.

I tried using Set text but it doesn’t work

I tried Type into but it doesn’t work because while selecting UI the entire box is selected but while typing the value the month, date and year have to be clicked separately before typing the value.


Did you try setting AlterIfDisabled to true? And when you say “doesn’t work” what do you mean? Nothing happened? The wrong date was entered? An error was thrown? You have to give us details or we can’t help you. “doesn’t work” doesn’t give us any details.


Did you Set Text or Type Into the date in the correct form dd/MM/yyyy?

Sorry for not giving any details on the error.
I used Set text as suggested by changing the property AlterIfDisabled to True.

The selector is

While I started the automation the date was

I used Set text activity, the automation did not throw any error, it was completed but did remained the same. there were no changes.