DataTable.Select() not working ONLY when run in Main

Hi everyone,

(I have read so many posts about this exact issue, but mine is still not working after trying all of the solutions/tips in other posts.)

I am on the first assignment in the Level 3 training. I have completed configuration and am trying to run Main in order to get filtered data from a data table (on the training ACME site). There are no errors in the workflow, but it keeps faulting at the assign activity that filters the data when I run Main.

WIList = acmeDT.Select(“Type = ‘WI5’ AND Status=‘Open’”)

*To test whether the code is busted or if it is an issue with the connection between workflows:
I copied the filter assign activity (with same code as shown above) directly into the data table scraping workflow (rather than being placed in Main/Init after the invoke activity for the data scraping workflow). I ran only the data scraping workflow, displayed the data table, and it did provide the correct filtered output. So the code is correct, but I think the fault issue I get when running Main is with the communication between workflows (between ACME_System1/ExtractDT.xaml and Main)? An issue with the arguments being passed?

I would appreciate any insight here.

Thank you!

Lvl3 Pract 1 - (1.0 MB)

Hi @shelbypons

Cannot check the attached code as I’m out. But based on what you have mentioned my guess is the arguments. So in the extract DT make sure assign the extracted DT to the out argument using an assign activity. In the main, make sure to grab the output of extract DT xaml into another data table variable which is used for the filtering

This should help

Thank you! My out_AcmeDT argument had the “Direction” set as In. (What a rookie mistake.) After changing that, it worked perfectly.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.