Datatable convert automatically from General Number to Date

I have this cell as General Number (format cell) in Excel (along with other cells):
5024/1/2

Then I have in place a Read Range Activity to read that sheet into a datatable.

But, finally, after I’ve run the Write Range Activity to output datatable back into Excel, I found that that specific initial cell General Number formatted just becomed Date formatted cell :
1/2/5024

How can I keep the initial format of the cell as General Number ?

1 Like

@IPIX Try this In read range activity enable Preserve Format check box.

I do not see that option.

Neither in Properties.

I’ve checked for Raw but nothing change, same issue.

@IPIX

After write range try using format cell/Range activity and format the rnage or column as required

Cheers

Tried already directly in Excel, @Anil_G. But gives general number of:

@IPIX

May I know this is cause by write cell or write range?

Did you happen to try using write range workbook activity?

Cheers

@Anil_G, write range workbook activity - this is what I’m using.

Hi,

Can you try to set DisplayValue at ReadFormatting property in ReadRangeX activity, as the following?

Regards,

@Yoichi, thanks but already tried all options from Properties of this activity.

Hi @IPIX ,

Could you show us the Format of the Cell before performing the operation ?

Do also perform a Debug and Check the values retrieved in the Datatable when applying Different ReadFormatting Options.

Let us know which ReadFormatting option gives you the format as same as present in the Excel.

You might need to add a quote ' at the start of the value i.e update the cell values by prefixing a quote using a For Each Row Activity and then Write the Datatable back to Excel Sheet.

Let us know if you were already able to solve the issue.

I’ve solved this as follow: simple adding a space in front of the cell value.

" "+row("columnName").ToString