Datascraping: extract correlated data not showing up

When I try data scraping, I’m taken through the normal steps to scrape data, but am not given the option to extract correlated data. It just asks me about a next page and then finishes the process. My version is 2018.4.5, is this not available to me?

Hi @Nicole_S,
It seems that you click OK on this popup window:
If you click No, you will click the second element and after that, you will see a bigger popup that has an “extract correlated data” button.
Hope this helps.
Thanks and regards.

1 Like

Hi @Jan_Brian_Despi,

I don’t see that popup.
Basically what I’m doing is going to ebay and scraping the title of each of the results. I would like to correlate those titles to the price of each item.
I’m following one of the practices from UiPath’s lesson site.


Oh got it. It is not a table.
Can you send me the link of that ebay site?
I tried data scraping on ebay:

And I manage to extract the names and prices using extract correlated data.

Here is the link:

After I select the titles, I get the configure columns window, and when I click next, this:

That’s where I can’t find the extract correlated data option

Finish just asks me if there are multiple pages, and then completes the process

1 Like

Hmm. Weird. Extract Correlated Data is included in 2017.1 documentation so you should have it

Is it possible for me to do a second extract and correlate the data manually?

Sequence.xaml (10.8 KB)
Can you try running this one? Thanks

1 Like

I’m getting an error.

I ran a debug, and it gets stuck in the open browser activity.

Oh. You don’t have the Chrome Extension yet

1 Like

Try this one instead: Sequence.xaml (10.6 KB)

1 Like

It looks like it worked. This is the result:

Yes. It worked. But I am really curious why you don’t have that Extract Correlated Data button.
@loginerror and @ovi, any inputs on this one? Thank you!

1 Like

Hi @Nicole_S

Strange. What is your UiAutomation package version? Could you try updating it and giving it another go?

You can check it in the Package Manager here:

1 Like

I had 18.4.2, so I updated it to 19.4.0 and tried again. I still have the same problem.

It might be some weird interaction between the UiAutomation package and your version of Studio :confused: I would suggest contacting technical support, as it is not supposed to happen (as far as I know).

They should know the answer and because you are the user of the Enterprise edition, you can contact them directly here:

Of course you can always try to update all packages to the latest versions and see if it will help.

1 Like

Updating the packages didn’t work :frowning:
I will contact support and see if they can fix it

Thank you for your help,

1 Like

I am having the same the problem
Please helpAnnotation%202019-06-19%20143638

Just Create A new Blank Project and It will Work Fine !!

1 Like

We recently found out one cause of this issue.
Nuget package Extended.Wpf.Toolkit is what our software relies on to generate this button and the spec of this button seem to have changed since version 3.3.0.

If 2.8.0 is not available in your environment,
Downloading version 2.8.0 from
and placing it in package feed may fix your issue.
Default Local package feed for Enterprise Edition is
C:\Program Files (x86)\UiPath\Studio\Packages
For Community Edition it is
%localappdata%\UiPath\app-xx.x.x\Packages (xx.x.x is the version of the Community Edition you are using)
Please try the above and see if it fixes your issue.