Database "Connect" action fails when used consecutively (even when Disconnecting)

Hi,

Currently i’m developing a process that extracts data from an Excel sheet for further manipulation.

I created a small sequence that has a Connect, Execute Query, and Disconnect stage.

When executing this sequence multiple times in quick succession, I get the error “Job stopped with an unexpected exit code: 0x000000FF” (Type: SystemException)

This does not happen every time. Waiting a longer period of time can allow the sequence to run normally, but this is not always the case ( i.e even after waiting 20 seconds the robot will still fail on the ‘Connect’ action).

The string is as such: “Provider=Microsoft.ACE.OLEDB.12.0;Data Source=”+Filepath+";Extended Properties="“Excel 12.0 Xml;HDR=YES”";"

With Oledb set as ProviderName.

I am thinking of building a Try-Catch with a delay of 30 seconds should it fail, but this seems like a band-aid solution.

For additional reference, this process was previously built using Blue Prism, and running OLEDB consecutive times there seemed to work fine, with the same parameters (the process is being rebuilt for UiPath).

Any help or suggestions on how to tackle this issue would be much appreciated!

Thanks in advance,

Nico

Hello…

When you use the connect activity, it will make a call to SQL Server to open connection so every transaction you no need to open and close the connection, use it at the beginning and end of the flow, It helps to speed up the transactions. May be opening multiple times it throwing error.
In this case you can use delay before the connect activity and test.

Thanks,
Meg

Hi Meg,

Sorry if I wasnt clear but I am opening different excels, given that they have different connection strings I need to establish different connections or not?

Also for what it’s worth, I put the 3 actions straight into my main project (so no longer invoking a workflow file) and doubled the disconnect action and the problem seems to have vanished. It’s not the cleanest solution but it works

EDIT: unfortunately this bandaid solution has now stopped working as well, think I just got lucky the first time…

1 Like

Hi NicoEsposito,

I am also facing the same issue.

I had a try catch, in try I called connect, query activities and in finally disconnect activity is called. I am having some set of records where i need to loop and call this activity. I am also facing the same issue.

Can you please help me to resolve this.

Thanks in advance

Have you tried to put a kill process to kill excel right before the connect activity?