Data Row To Data Table

Hello.
I am having an error of below and can someone explain me why and how can I fix this?
Thank you. :smile:


@hsupyaewoon

Have you checked Add Headers option in Read Range activity or not ? It didn’t find ColumnName Hanry.

Could you please show me screenshot of that expression you mentioned in Assign activity and so that we can check and help you.

1 Like

Hello @lakshman
I have checked Add Headers and also Read Range activity goes well.

I have two different excel files.
One has three colums “Name, Mail-Address, Mark”.
And another one has also three colums “Name, Leader’s Name, Leader’s Mail-Address”
So I am now trying to send mail automatically whose mark is more than 80.
Not only to the persone who’s got more than 80 marks but also want to send mail to his or her leader.
I could send mail to the person who’s got more than 80 marks but I don’t know how to send to leaders.
To send mail to the leaders, I have to take out the leader’s name and mail-address from another excel files and have to match the names of this file to the person who’s got more than 80 marks from the first excel file.
The problem is I can’t do really well to match the names.
Please help me with this.
Thank you.

@hsupyaewoon

The mentioned select query was wrong here. It should be like this.

            newDT = yourDT.Select("[Column1] = 'Value' AND [Column2] = 'Value'........[Column N] = 'Value').CopyToDataTable
1 Like

@lakshman
I am sorry but I don’t really understand.
image
image
This is the example file and the screenshots below is how I was doing with UIPath.
Can you please check for me ?
Thank you.




@hsupyaewoon

You can Join the 2 data tables from your 2 data sources:

image

Then filter out the resulting table to keep only those with mark > 80
image

Finally loop through the datatable and send notifications.
image

Check it here:
Test003.zip (23.3 KB)

1 Like

Hello @JGuarino
Thank you for your answer but the error is coming out like this
image

@JGuarino
Ohh.I am sorry. I didn’t notice the space.
Thank you.

@hsupyaewoon

Can you confirm you have the AddHeaders option checked?

1 Like

@JGuarino
Yes.
It is solved.
Thank you so much.

@lakshman
@JGuarino
Thank you two so much.
I have learnt new things today.
There was no one who can explain me and teach me new things like this since I have started learning by myself.
I was stuck and trying some of the ways I knew only.
But now the problem is solved and I also get more new knowledge because of you two.
Thank you.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.