Data masking issues in the new release 2018.3.0


I am facing data masking issues in the new release in 2018.3.0. This was working fine in the earlier release but since UiPath got updated to 2018.3.0, even after using wizard to extract data, it is not working. Can somebody please help?

I have an urgent delivery so will appreciate a speedy response.


Shows the below error each time, even after trying multiple times, data scrapping:


Source: Attach Browser ‘MyDirectR Page’

Message: Cannot find the UI element corresponding to this selector:

Exception Type: UiPath.Core.SelectorNotFoundException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
UiPath.Core.SelectorNotFoundException: Cannot find the UI element corresponding to this selector: ----> System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector:
at UiPath.UiBrowserClass.Find(String bstrSelector)
at UiPath.Core.Browser.Find(Selector selector)
— End of inner ExceptionDetail stack trace —
at UiPath.Executor.WorkflowRunner.EndExecute(IAsyncResult result)
at UiPath.Core.Activities.InvokeWorkflowFile.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

@Ruchi_Srivastava This is pure selector issue check selectors in attach browser

I already edited the browser multiple times and it still shows the same error each time.
NB: I am using wizard to scrap the data from a website.

@Ruchi_Srivastava Try this use open browser and in the uibrowser properties create variable(v1) and use attach browser in the browser properties pass variable (v1)

I didn’t understand. Can you please elaborate?

@Ruchi_Srivastava Is it possible to share the url that you are trying to scrap

Sorry Its a client URL. I will not be able to share.
Nonetheless wanted to inform that the data scraping was successful in the earlier version…

I uninstalled the UiPath and installed once again afresh. The first time it worked but the second time onwards I am getting the same problem again. Not sure what is the issue.

Please guide.



I am sharing part of xaml file. Hopefully this will get an idea what I am trying to achieve.

My issue is the selectors are very inconsistent. Sometime these work. Sometimes not. I have spent a considerable time trying all permutations and combinations but havent yet found a permanent fix.

Can somebody please advice?

1 Like

Perf.xaml (69.7 KB)


Have you managed to find a solution. I am having a similar problem, the old release picked up elements in a desktop app (Microstrategy Command Manager) that uses java, but the new release wont.