CVS special characters ä,ö,ü, ß

Hey,
I’m using the Read CSV activity on a csv file and append to csv. The csv have special characters ö,ä,ü and ß , The new CSV replaces these characters with some question mark character.

I set the encoding on the Read CSV activity to utf-8 already.

Anmerkung%202019-10-21%20143235 Anmerkung%202019-10-21%20143452

1 Like

In such cases a check e.g. with notepad++ of the csv file can help to check

  • for character set to use
  • encoding issues in the csv

then the read csv activity should be configured to the encoding set as applied in csv file

In case of corruption or Schmutzzeichen already present on the csv a correction is to plan (manually, tool based)

i cant install notepad++ on my workplace

i cant install notepad++

alternate options could be:

  • portable version of notepad++
  • checking the CSV file outside of machine on anoher machine
  • doing some prototyping with Powershell by readin / write out the csv and trying with different encodings
  • in case there are only this 24 values recreate manually a new CSV and get control on the used character set
1 Like

Have you tried setting the encoding to “ISO-8859-1” instead of UTF-8 ?

br,
Topi

Yeah, i tried all from https://docs.uipath.com/activities/docs/supported-character-encoding

ok portable worked :slight_smile: thx
The CVS file A “Encode in Ansi”
The CVS file C “Encode in UTF-8-BOM”

ok it worked :slight_smile:
In Read and Append --> Encoding “iso-8859-15”

1 Like

@BjoernMikolajewski great news. Do you want to close topic with the solution flag as it is working?

How does that work?

@BjoernMikolajewski
As you are the author of this post you can flag the helping information with the solution flag:
grafik

So others members:

  • can see that it is solved and invest their time on open topics
  • researchers can easier identify the working things
1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.