CV Extract Table Activity Not Refreshing

I have a couple of older automations (circa August 2021) that I use the CV Extract Table activity off of a VDI. The scope checks for multiple pages of tabular data, sets it to a variable and then runs the “Repeat Number of Times” activity with the repeat variable set to the page numbers. As it goes repeats, it does the “CV Extract Table” activity to get the current table. There are no issues with these automations.

I am building a new automation, using the same activities, but with the most up-to-date versions. When I run the same process on the repeat, it extracts the first page of the table, then navigates to the next page. Once it’s on the next page and runs the extract activity again, it isn’t changing the result and it just includes the data from the first page. I tried the “clear data table” activity and when it goes to the next page, it’s not populating any new data. The tables are the exact same structure and works no different than my older automations. I have the “RefreshBefore” set to “True”, so I am at a total loss here. Is this a bug?

Hi @Houston_Hagaman

Does updating the old automation (please make a back-up before) to the latest package have the same issue?

Is the descriptor for the new activities the same as the old activities?

Can you please share your workflow?

Best regards,
Stefan

I have also same issue. The process is getting data from multiple items, when process goes on new item I clean all variables and proceeding with next item, and somehow CV Extract table activity gets old values from previous item.

Here are the versions of package which I’m using:

image

Thanks!