Custom SOAP request returns wrong variable type

studio
p_qa
soap

#1

I have created a Custom SOAP request, which gets a response. However, the return type is not a string but "wsBudsjettregnskapDvh[]. When i try to run the workflow i get this error.

Capture1

The type is unknown. Has anyone else experienced this?

Is this something i have to rewrite in the code or is there fix in UiPath?

Please let me know.


#2

Hi Nicholas,

Please check if there are any updates for UiPath.Web.Activities and UIPath.V7 Compatibility Pack.


#3

There is no new updates to web.activities or V7.comp pack :frowning:


#4

I solved this issue by using the HTTP request activity, and called the SOAP service from there. I tried with a custom SOAP request and the SOAP request acitivity from UiPath. It seems like there was something wrong with the response and the SOAP request activity could not read the response. There might be something wrong with the service that I am getting the information from. However, it seems weird that the HTTP request activity could handle it and not the SOAP request activity. If anyone had similar experiences with this please share :slight_smile:

I will look out for updates for those activities you mentioned @ovi and test again.