Custom Library Nuget package Throw an error regarding namespace and assembly error

Hi UiPath,

Hope all are doing well.

I have an issue regarding the library, I had created a custom library and published that custom library on a local machine.
And install a custom library NuGet package in the process. After that, I published a process and that published process NuGet package execute on a different machine through the robot.

It throws an error like, image

Is there any solution regarding an error?

Thanks.

@sams

Please check once whether you updated all required packages or not ? If not then do it first.

@lakshman,

I had check all packages look good in that NuGet package.
When I tried to execute process NuGet package through robot it through the same error on the screen.

I think when I publish process, all dependencies are automatically published in a process NuGet package.
Right?:thinking:

@sams

Is the custom library present in your local machine and you are trying to run the process which is using this “CUSTOM LIBRARY” in a different machine? I believe the other machine won’t be able to install this library as part of dependency and you need to have it somewhere where both these machines are able to view/edit it.

@Indrajit_Banerjee,
Yes, exactly I published library on local machine tried to execute on different machine.

Also I had tried to put Library Nuget package on Shared folder, which is connected with both machine.
Same error occurs in that scenario also.

If any suggestion regarding same than suggest me better solution for overcome this issue.

Thanks.

@sams
So i would like you to do this step one more time but with the following changes:-

1.Publish the library to the shared folder directly from your dev machine and utilize the same in your workflow(make sure you download the library from the shared drive).
2.Publish the whole process and then try running it from the other machine .

@Indrajit_Banerjee,

I just tried same thing which you suggested. It throws same error which is attached above.

I there any other way to execute process which is installed library package in process nuget package?

@sams
By Any chance can you pass me on this custom library?

@Indrajit_Banerjee,
here, I shared a sample.
Library&Process&Nuget_packages.zip (32.7 KB)

Hope you understand and try to resolve the issue.

@Indrajit_Banerjee,

After installed Library package in process, I see image error in output panel of studio.

image

@sams
i am able to install the library properly and run the process as well.

@Indrajit_Banerjee,

You can try to execute only process nuget package.(put in C:\ProgramData\UiPath\Packages)
Which is already install library nuget package.

Note: without installing library nuget package.

I’m not sure if you ever got a solution to this but I ran into it myself.
Placing my custom, published nuget package here resolved the problem:

C:\Program Files (x86)\UiPath\Studio\Packages