Custom activity, storage bucket - Bug in UiPath.System.Activities 22.4.1

Created a custom activity that uses a Storage Bucket to get a file and read it.

Works fine when I run it in Studio from the library code. Publishes fine. No errors.


When I add the dependency and try to use the activity in another project:

When I downgraded (in the project where I’m trying to use the custom library/activity) from UiPath.System.Activities 22.4.1 to 21.10.5 the error went away.

More issues with this. When I run the custom activity directly via Studio, it properly reads the file showing these column names:


When it’s used as an activity in another project:


I verified that the file it is using has more than one row and does, in fact, have both colums.

This was because the Range was not filled in for the Workbook Read Range inside the custom activity. Per the documentation, it should read the entire sheet - and when run directly it does. But when run from the library in another project, it doesn’t. I had to explicitly fill it in as “A1” for it to work correctly.


Any response from UiPath? I am also reporting another bug here: Boolean parameter in Trigger is NOT overriding package default

Responses from UiPath would be nice.

The issue has been added to the tracker and it will be treated by our team in future releases.

I’ll keep this topic up to date about the progress.

I am currently trying to retest it and it doesn’t seem to reproduce for me on a Windows project with System 23.10.2 on both my library and the process.

If it is still an issue for you, could you maybe share the sample library process that was causing this issue, as well as the System versions for the project where the library is used?