Custom activity package not visible


I have tried following several tutorials about creating custom activities.

I have followed them to the letter, but not one single time am I succesful in adding the built nuget package to UiPath.

I have built the activity in Visual Studio, created a new Nuget package, placed in in a path that is added to the sources in the UiPath package manager, but no available packages show up, that I can install.


1 Like

Hi @jjes,

Welcome back to the Community.

Have you created nuget package with name ending as “.activities”

Hi @jjes,

Here are the steps to add dll to the UiPath packages.

  1. Select c# Class Library
  2. Add references system.activities and system.componentModel;
  3. Write the required code to be executed
  4. Define the input and output parameters
  5. build the solution
  6. Go to the containing folder and open bin folder
  7. open the Nuget explorer and create new library and add the dll selecting the add existing option
  8. Click to edit and change the name of the package
  9. Save the package file with the desired name and copy the file(.nupckg extension) to the path C:\Users\username\AppData\Local\UiPath\app-18.4.0\Packages
  10. Open UIPath and search for the name and click install you will be able to execute the code giving the inputs

May be the issue is with the Nuget package explorer part. Try doing all the steps again :slight_smile:

No I haven’t.
None of the tutorials mentioned this, only to build a .nupkg file.
Should it then be "mypackage.nupkg or mypackage.nupkg.activities, and is simply renaming the already generated file enough?

1 Like

@HareeshMR, no such path (as in step 9) exists.
Mine goes c:\users<username>\AppData\Local\UiPath and in this folder I have these folders:

Open the UiPath folder you have. Check the version of your UiPath studio and inside the UiPath folder, you will have another folder with the name of your studio version.

You can get the path of the application installed as :
In the start menu, search UiPath, right click and open folder path. You will get the UiPath Icon and again right click on the icon and open folder path. You will get the packages.

@Vivek_Arunagiri: Got it!!! :slight_smile:

In Nuget Package Explorer, the ID property of the Package Metadata must end in “Activities”.

This is - if you ask me - a stupid convention, but hey… it works now :slight_smile:
Thanks for input!


Make sure you have placed the package in the right path.

You can find the path as :

  1. Click on Manage Packages
  2. Go to settings
  3. You will get the right path to place the .nupkg file under local check box

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.