Creating new process in Studio fails with Culture is not supported exception

I run into the following error when trying to create a brand new process once I open the studio
Error: System.Globalization.CultureNotFoundException: Culture is not supported.
Parameter name: culture
22538 (0x580a) is an invalid culture identifier.


Studio version = 2018.4.1

My native windows has the Costa Rica locale setting, but I am using a virtual desktop in the US locale to access the studio. The Studio has English as a default language.

I even tried resetting the settings in the studio but it did not help. Any idea how to address this issue. I have a co-worker with an exact setup and his works without any issues. I switched to another Virtual desktop and I get the same error message in that virtual desktop as well.

@Sumit_Shrestha,

Can you please check this link. this might useful for your query.

https://studio.uipath.com/docs/importing-new-namespaces

Thanks,
Arunachalam.

I cannot even open any project to update the namespace in the import tab. As soon as I click on new Process i get the error message and it blocks me from creating a new project/process and go to the workflow editor.