Create Custom Rule In Workflow Analyzer

Thanks for your kind response @nerlichman .I have fixed that issue.

1 Like

Really helpful video - thanks!
In case anyone else finds it helpful, I’ve attached class file for the demo code in the webinar video:
clsVariableNameRule.cs (2.7 KB)

I initially couldn’t get rule to appear either but realised I got the string literal WorkflowAnalyzerV4 wrong :slight_smile:

2 Likes

Hi Hawkins, i am trying to build custom rules, as per the documentation we need to add uipath.activities.api nuget package in the visual studio 2019, but i couldnt see it and there is no documentation mentioned anywhere on how to add the reference.
Pls can you help me on this.

Hi @manikandan.lagichetty

have you checked here?

1 Like

Okay i got this resolved. Initially when i clicked managepackage in visual studio i was not able to see uipath nuget package name in the package source settings. Then i added the uipath nuget package url.
Thanks for your quicker response. :slight_smile:

New Rule not reflected in Workflow Analyzer:
Now i am trying to put the dll to see the new rule available in the Workflow analyzer. As per the document it says to deploy the dll in “C:\Program Files (x86)\UiPath\Studio\Rules” but uipath has been installed in C:\Users\LBM\AppData\Local\UiPath.

I tried to place it in
C:\Users\LBM\AppData\Local\UiPath\app-20.4.3\Rules
C:\Users\LBM\AppData\Local\UiPath\zapp-20.4.1
Still i am not able to see the rule i created in WorkFlow Analyzer.

Can you pls help.

I’ve just checked my own Community installation (that’s the difference here), and the path is this one:
%localappdata%\UiPath\Rules

Tried but still not reflecting.
I placed the dll in the path as u mentioned
Opened uipath project
Verified the workflow analyzer settings to see the rule i created is visible or not.
Is there anything i missed out?

Hi anybody faced this issue? I am still not able to see my custom rule in uipath. Any help much appreciated.

I would suggest you to go over this video here:

It goes in detail, and step-by-step, on how the process should look like :slight_smile:

Finally could figure out the folder where i suppose to put in the dll. Thanks for your support.
Just a suggestion:

  1. DLL Path apart from the default location as mentioned in the video (i.e. program files (x86)/uipath …/rules), for me, it is not a default path so i need to place the dll in the path “C:\Users\LBM\AppData\Local\UiPath\zapp-20.4.1\Rules”
    If this can also be mentioned in the documentation it would be easier for everyone.

  2. In the demo video, Manage NUGet Package->uipath nuget package alread been added, instead if they showed the how to add the nuget package and then download the uipath.activities.api it would be helpful especially for the people who are trying for 1st time.

  3. Last one: There are rules we can add at different levels like at activity, at workflow, at project level. If possible if we have demo for all 3 or a documentation it would be very much helpful.

Thanks again for all your support.

2 Likes

Hi @Hawkins,

I am facing the same problem with you that the custom rule is not show up in 2019.10.1 Enterprise Edition but working well in Community License.
Could you help me on this please?

Is it still possible to attach to the analyzer using VS2019, as per below post? I’ve just tried it but there was no UiPath.StudioAnalyzer.exe process to attach to.

@jakub.koster Yes, you can use Visual Studio 2019 to connect to the Uipath.Studio.Analyzer.exe process (which is also still present in UiPath Studio 2020.10.2).

You must have UiPath Studio open before you open the window to attach to the process in Visual Studio. Otherwise, you may have to click the “Refresh” button, in the attach to process dialog, to see the newly started UiPath Analyzer process. I believe it takes a moment after opening UiPath to start.

@cclements Hi Chris, thanks for reply.
I am using UiPath Studio 2021.4.3. I followed your instruction and waited ~2mins, then refreshed again. But it seems that analyzer is simply not there. Perhaps it changed in later version.

Hi @jakub.koster

As a side effect of the multi-process architecture for the .net core, the name of the process does not show up as WF Analyzer but as Studio launcher.

We will look into ways this can be improved, but that would be the workaround until then.

1 Like

Attaching to Studio Launcher worked. Thank you for reply Maciej.

1 Like

Thanks for the tip, it’s really helpful.