Couldn't upload project and failed twice, please help with clarifications

Attempt 1: They update UIPath application midway my exam from 19.5 to 19.6 and the it hanged every time I tried to debug the solution, couldn’t stop the debugging. I had to force close the process from task manager and reopen it again and again, taking a lot of time.

Attempt 2: The Catches block was not catching my BusinessException even after using UiPath.Core.BusinessRuleException. I wasted a lot time here and after a while i removed it and inserted back manually. Then it worked but I had lost substantial amount of time over this potential bug. Later I struggled with converting datarow to datatable, got it eventually after the exam.
And while debugging the code I didn’t knew we have to click continue about 6 to 7 time to throw it to the next activity. I was struggling for it to go out but it never did, I just continued clicking on continue and then only it moved out.

Are these bugs or this is the way it works?

Also, please clarify the following issues:

  1. We don’t need to use dispatcher-performer until stated in the problem statement, right?
  2. Exactly which files are required to be uploaded, the whole project, or just the xaml files with output excel.

I have completed L1, L2 and L3 including two assignments but couldn’t upload solution in time. Doesn’t feel right at the moment I would take my last attempt in a few days.

Since nobody replied, i would reply to myself.

  1. There is no clear resolution to such problems but when things doesn’t work we can try to remove activity then reinsert it back and restarting the whole machine also seems to help sometimes, the drag-drop bug is resolved in 2019.6 though.
  2. Use dispatcher-performer structure only if mentioned in the guidelines.
  3. We can zip the whole solution and then upload.

I did clear the certification in my 3rd attempt.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.