Could not find the user-interface (UI) element for this action in type into activity

I have built a bot that basically fill in an online form based on rows data in Excel.
Everything works perfectly for my first row. I use a for each row in datable activity and when it look a the 2nd row in the excel file and try to type into I got the following error message Could not find the user-interface (UI) element for this action

How can I solve the problem of selector?

Thanks in advance for your help.

@mce

What selectore are you using?

looks like you used innertext porperty which might change for text field once text is typed

cheers

@mce

can you refer this

Studio - Dynamic Selectors (uipath.com)

Modify selectors: Based on your findings, modify your selectors to be more robust and account for the UI changes. Use the following strategies:

  • Avoid idx or index: Consider using other unique attributes or combinations for more reliable identification.
  • Use wildcards and partial selectors: Employ wildcards (*) for dynamic attributes or parts.
  • Relative selectors: Leverage parent-child, sibling, or ancestor relationships.
  • Class name contains: For dynamic attribute values (e.g., classes), use contains instead of exact matches.

Hi @mce

May be in second iteration you are entering data in the same field right.

If yes, while indicating the element for type into activity in the selectors option window, select the ignore text option in the drop-down in fuzzy selector.

This will ignore the text in the text box in next iteration and it will enter the data.

Hope it helps!!

Hey @mce
you can try use:

  1. Dynamic selector - Make the selector dynamic by identifying the parts of the selector that change and replace them with wildcards (* ) or use variables that adjust according to the row you’re processing.
  2. Anchor Base - In the Anchor Base activity, use a Find Element or Find Image activity to locate the anchor , and then use the Type Into activity to interact with the target element relative to the anchor.

I tried do proceed as you all explained but without success.
Noted that Im using an application type into activity.
Im using a target and together with an anchor.
Fuzzy selector of the anchor is: “”

Strict selector of the anchor is :

Fuzzy selector is:
“”

Strict selector:

Should I used CV Type into instead?
I’ve tried to create dynamic selector but without success

Thanks in advance for your further help.