Could not find a machine in the current folder

I cannot add local users so the video does not help.

Is it no longer possible to use unattended and attended processes from orchestrator as a community user or do I have to enable local users somehow to make it work?

I managed to solve one error but I have still one big issue.

Discovered that my orchestrator URL was wrong. Instead of: platform.uipath.com it should be UiPath. Now my attended processes are visible AND my unattended are running.

Unfortunately on my other PC I am not able to get unattended running because I am not able to create a new user in orchestrator. Does this mean that community users cannot any longer use unattended on two pc’s since the update to modern folders?

Actually, it is doable for modern folders if you create a Cloud Account for that second machine.

1 Like

Thanks for the tip. It took me quite a while to figure it out.

The steps are:

  • Made a new cloud account
  • Linked the new cloud account with my old, adding the new account as new user and giving automation user and administrator rights
  • Confirmed the link/invitation sent to my new cloud account
  • Logged back into my old cloud account
  • Added the new user cloud account
  • Added automation and administrator roles
  • Used the machine code on my second pc
  • Probably did some more tweaking which I cannot remember

And finally got the setup of having unattended running on two pc’s AND being able to see attended processes. Just like with classic folders but spent 20 hours tweaking and tvisting, clicking desperately trying to figure out the logic.

1 Like

Solved with the help of this link Managing Unattended Robots in Modern Folders with some modifications for latest version.
Recommended steps:

  • update uipath (assistant): normally i downloaded studio and it installs the assistant
  • configure modern folder in the tenant as needed. I have used the community version, so by default modern folders are enabled and is partially disabled to go back to classic folders.
  • verify that you have connected the uipath assistant to orchestrator and that resources has been created in orchestrator: machine template, user, robot.
  • edit machine to give licenses (i have bring 1 unattended and 1 for testing runtimes)
  • edit user to give:
    • In user details: give “robot” and “automation user” roles
    • In unattended section: toggle the option “automatically create an unattended robot…”, and give windows user credentials and user (in commandline you can type whoami to get this complete name).
    • In Robot Settings: define the logging level and enable automatic downloading of process.
  • Bind the user to the folder: in this case the default folder was “shared”, so I go to the tenant / folder section; then select the shared folder and
    • I’ve added the user (indicating that you would like that user is allowed to be an automation user).
    • In machines section, I’ve also added the machine template to folder.
  • Then in the monitoring section of shared folder you can validate that you have access to see the machines connected, bind and working.
  • Try to do a manual execution of an automation started from the orchestator to check that all is working.

(all this because the way to manage folders has changed in previous recent versions)

hope that it helps

Hello how are you?
I had the same problem and managed to solve doing the following:
Screenshot by Lightshot ( Image)
First click in “Tenet”
Second click in “Machines”
Third On the machine you want to appear click on the 3 dots
Click in “edit Machine” Screenshot by Lightshot
in "License - Unattended Runtimes (execution slots) " select the number of licenses: Must be greater than 0 like 1 for exemple Screenshot by Lightshot
and Click in UPDATE
Now your machine will look like this Screenshot by Lightshot

Sorry for my English. Hope this helps