Could not find a machine in the current folder

I am getting this error while running job, Suggest me any solution?

Check if your robot is connected and machine also

It is connected still it is showing error

Hi Chandu, you have to set Environment first and then configure a robot for that defined environment in the Default Classic Folder. You can follow the steps below in Orchestrator and refer to the image attached when it is needed.

  1. Change to Class Folder on the top right of Orchestrator
  2. Go to Management->Robot-,Click Environment, Click cross “+” to create a new Environment
  3. In the new Environment, Click the three vertical dots, Select Manage
  4. Check your robot
  5. Go to Automation->Process, Create a new process and link it to your Environment
  6. Go to Monitoring->Click “Jobs”, you can run your bot from here by creating a new job. You will be be able to see the robot configured for your environment.

It is noted that the setting for Shared Folder is different from that in Classic Folder.

Good afternoon! I have a similar problem. My robot still does not appear in “Monitoring -> Start Job”. I followed all the steps, my robot is connected but I still have this problem =(

I have the same error. I would like to know the instructions how to fix the problem with the modern folder configuration, as that’s what my uipath orchestrator is asking me.

My process is visible in UiPath assistant, my robot is connected, licensed, and the process is started.

But when I try to start the process from the UIPath Orchestra interface online, it says that it “Could not find a machine in the current folder” #2818

In the top right corner, we can see that I have 0 available unattended machines, even though UI Assistant tell me my machine is connected, licensed.

Edit: I think I understand the problem. It says we have 0 available unattended machines, even though I should have one with my uipath orchestrator cloud community version. See below.

image

Hi P_Botrel, did you see the unattended robot when you define Environment? You need to to check the robot when you define Environment.

Environments are not used in the context of Modern folders.”

I can’t define an Environment.

Any solution?

I have the same issue. Due to an error with UiPath in Firefox I had to update UiPath to the newest beta version. This partially solved my Firefox problem but in the update Orchestrator has been redefined with modern folders etc. All my unattended triggers does not work any longer! I have spent hours trying to setup different scenarios but I am not able to get the problem solved.

Please UiPath developers - when you update then do not let us behind in the dark!!! Give us some guidelines how to migrate.

I have also a similar issue though my folder is modern and it says I’m connected to the Orchestrator in the Assistant tray. However my process within the folder is not showing up in the Assistant.

. The license allocated to the User (Marked as a Robot role) is an unattended license. I’m able to run the process fine in studio (there’s the usual disclaimer for using unattended license in the beginning).

Your problem with assistant and processes not showing up will be solved by following this guide: Studio Sign In Guides

Unfortunately by following the guide and moving to modern folders your unattended processes will stop working!

Could someone please give me guidance how to reactivate my unattended processes when using modern folders?

Attended are working fine and showing up in Assistant.

Hi @raven

See if this video helps you:

The video tutorial unfortunately does not show how to create machines for the tenant. When I create a machine for the tenant the installed version is “no robots” and I get a Machine key that I do not know the purpose of.

Help would be appreciated because my unattended robots have not been working for quite a while,

For modern folders, and after you’ve created the machine template for your tenant, navigate to your modern folder and then Home -> Machines
image

Simply add your machine template there, and as long as your Robot user has access to that folder, it will execute the process on the available machines per added templates.

When my robot user uses the Machine key then the unattended process is running BUT no attented processes are shown in the Assistent. So the big question is now - how do the robot user use attended processes AND unattended processes without logging out as user and then logging back in with machine key?

Works for me. I set authentication with machine key, 20.10 version. My users has only unattended license. The processes are displayed in the asistant.

You may find this video helpful as it runs through the steps
https://www.youtube.com/watch?v=M3Y3cZ408pg.