Could not connect to UIPath Robot service.make sure the service is started

Hi ,

While I am trying to run my robot I got the issue “Could not connect to UIPath Robot service.make sure the service is started.” Kindly help me.

Try these -

1 Like

Hi @Abudhahir - please open your local services and check if the service “UiPath Robot” is running as shown in the picture below:

1 Like

Hi all,

I have actually the same issue, but the UiPath Robot shows “running” in the services table. I have the latest version 2019.4.2.

Does anyone has a solution?

Thanks for helping! :slight_smile:

Best regards
Simon

And thats the error message:

System.Exception: Could not connect to UiPath Robot Service. Make sure the service is started!
at UiPath.Models.UiPathDuplexProxy.FaultTolerantProxy.g__CheckService|10_0()
at UiPath.Models.UiPathDuplexProxy.FaultTolerantProxy.CheckAvailability()
at UiPath.Models.UiPathDuplexProxy.FaultTolerantProxy.get_Channel()
at UiPath.Models.UiPathDuplexProxy.GetRobotConnectionStatus()
at UiPath.Studio.Plugin.Workflow.Services.RobotStudioBridge.Execute(WorkflowDocument document, Boolean isDebugging)

Make sure if Older versions exists and maybe causing conflict with New version. Verify Admin Privilegies too. Uninstall and reinstall latest, reboot and try again.

1 Like

Hi asesor-rpa,

thanks for your quick reply - but it did not work.

What else could it be? Is there any option to install an older version maybe? 'Cause with all older version, everthing went well.

Best regards
Simon

Disable antivirus and check events log viewer to see what happens when service starts. Stop and Start manually from services panel

Hi Asesor-rpa,

unfortunately, I am not able to stop it manually.

Does the screenshot help?

Best regards
Simon

Solution: Sounds strange but did work: I took an older link to download an older version of UiPath software. Somehow, they transformed the link so I got the latest version anyway.

BUT: Then it worked - maybe it will help. Just take another link in case you have my descripted issues.

Thanks to all of you anyways :slight_smile:

Best regards
Simon

1 Like