Could not connect to UiPath Robot Service. Make sure the service is started!

it works

1 Like

I am also faced same issue but it resolved now

Goto–>All Programs–>Services.msc–>it will open the all windows services -->start the uipathservices


Hello, I have the same problem with version 2016.2.6274 .

In services.msc the run button is blurred. How can I solve it?

Hi @bogdan_margarit,

I had this problem this week with the same UiPath version and once I have repaired UiPath with the installer, it started to work again.

I tried to repair but it gave me an error when trying to start services. The error is that I don.t have enough rights to start services.

Hi @bogdan_margarit,

This message occurs when you don’t have admin privileges in your Windows PC, so in this case I suggest you to ask for someone else who has those privileges.

This will be because of hardening of the system

Hi @Thiago : I am not able to find the UiRobotSvc in my services list. Any ideas why it is not appearing there ?


Same issue,

same workflow was working well before 2 weeks

Hi ,
How about running from directory
C:\Program Files (x86)\UiPath Platform\UiRobot.exe

1 Like

hello @ddpadil thank you for response, I tried the same no success ,



1 Like


Do you have admin access.
Could you try opening service from task manager and try to start the service from the there.

1 Like

@ddpadil, thank you for response was showing access denied when i tried it manually, as of now it is working ok after I started the system next morning :wink:


I don’t have option to Start services. How do I start it?

1 Like

I also face these kinds of situations. But after restart my PC my problem get resolved.

Thanks :slight_smile: it works

Nice !!!

You can keep shortcut of Robot - UiRobot.exe on your desktop and use it to restart the robot.

1 Like

I tried this , But ui path robot service is Not showing in that

I am facing same issue and couldn’t find UiRobotSvc in the list.

1 Like