Could i add our own Nuget server with Uipath?

We would like to use our own NuGet server, but UIpath doesn’t seem to find the activities.

  • Those activities are found in local folder source package
  • Visual Studio nuget manager found all the activities.

is there an especial config we didn’t apply?

thanks in advance.


Hi Carlos,
You can use your own Nuget Feed (or Nuget server how you called it) for Packages that have to be executed by the robots, but not for Activities.
If you have your own nuget feed, go to Settings in Orchestrator and navigate to the Deployment tab. If Orchestrator is version 18.3 or 18.4, make sure you turn off “Internal deployment”. Then you need to specify the complete URL of your nuget feed (including the protocol, http or https).

UiPath Studio will be able to publish there if it extracts the API key from Orchestrator.

For Activities, we the have the LIBRARIES menu item on the left. You can upload new activities or new versions of an activity with the button on the upper right. The robot will try to download from Orchestrator every activity pack that is listed in the Dependencies section of project.json.

1 Like

Hi Ovidiu,
First thanks a lot for such a elaborate answer.
Unluckily our problem is we want to have our own activities packaged outsite the orchestator for security issues. Even in case uipath have not this setting, is there any “trick” to config our own nuget activity server ?

Hi @Carlos_Hxc

Would this page in our documentation help you?

Especially this paragraph:

If you want to add a custom NuGet feed that requires authentication, you can follow the steps explained here, and properly add the NuGet feed, username and password values in the NuGet.config file, located at the following path: %AppData%\NuGet . When it’s done, the feed should be visible in the Package Manager

1 Like

This is awesome!! this is what i need :slight_smile: thanks for not forgetting me here!!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.