Copying file will remove "Add headers" from Read Range Activity

excel
activities
p_solved
readrange

#1

Scenario:

  • Copying file will remove “Add headers” from Read Range Activity

Steps to reproduce:

  • Create XAML with Excel Read Range Activity and select “Add headers” for that Activity
  • Save file
  • Copy file to another location

Current Behavior:

  • Every now and then “Add headers” option is not anymore selected in new copy of the file

Expected Behavior:

  • File should not be modified while copying

Studio/Robot/Orchestrator Version:

  • Studio 2017.1.6435
    Last stable behavior:
  • Studio 2016.2.6442
    Last stable version:
  • Studio 2016.2.6442
    OS Version
  • Windows Server 2012 R2
    Others if Relevant: (workflow, logs, .net version, service pack, etc):
  • None

Does anyone else have noticed this issue?


#2

Please check this attached file once

copy one excel to another.zip (9.8 KB)


#3

Hi,

Problem was not related to UiPath functionality. It is about copying xaml file :slight_smile:
If you copy xaml file that includes Read Range Activity with “Add headers” option selected, every now and then that selection is removed from new file (copy of original file).


#4

@Andrei_Pop


#5

It does not matter if you copy the file, the problem seems to begin locally when you save the file.
The AddHeaders=“True” parameter is not saved at all. Only when you remove the checkbox tick, the XAML file will have AddHeaders=“False”.

Without the saved parameter in the XAML file, any new computer will not have the checkbox ticked, but it stays in the local version; it must be saved locally in some other way than the XAML file.

Modifying the XAML manually will help, if you add the AddHeaders=“True” parameter to the file, it will also work in any other computer. However, if you ever modify and save that file again, that parameter will again be missing from the XAML and you have to remember to add it manually again.


#6

Yes, I noticed same kind of functionality and it is very annoying. Hopefully UiPath will fix this soon :slight_smile:


#7

Hi Mikko,

Have you tried with the last version 2017.1.6522? I cannot reproduce, maybe it was fixed.


Losing some functionality when I deploy to a robot
#8

Hi,
It still does not add AddHeaders info to XAML with 2017.1.6522. Below You can find out example of XAML part that has Read Range activity with “Add Headers” selected;

---------------- 8< -------------------- 8< ---------------------

<ui:ExcelReadRange DataTable="[hoo]" DisplayName="Read Range" SheetName="Sheet1">
  <ui:ExcelReadRange.Range>
    <InArgument x:TypeArguments="x:String">
      <Literal x:TypeArguments="x:String" Value="" />
    </InArgument>
  </ui:ExcelReadRange.Range>
  <sap2010:WorkflowViewState.IdRef>ExcelReadRange_1</sap2010:WorkflowViewState.IdRef>
</ui:ExcelReadRange>

---------------- 8< -------------------- 8< ---------------------


#9

Thanks for this thread. I am experiencing exactly the same problem. I have 2 choices. Manually add the AddHeaders=“True” to the .XAML file and publish. Or drop the headers all together from the Excel. Either is not pretty and frustrating!


#10

I also have encountered this issue. When I publish my project and upload to Orchestrator, I was getting no column found errors because the Add Column Headers was deselected upon saving.

It is not a huge issue to insert the addheaders=true into the xaml file, but it will get tiresome after a while to unzip, edit, re-zip every time I have a new iteration to upload to Orchestrator.

Hopefully this can be resolved on an update soon.


#11

Same issue here, i had to hardcode the excel column index for all my assign(up to 45 column in my usecase). Hope it will be fixed asap, this features is the only way to avoid error due to manual changes on the excel input by the final user…


#12

Hi there,

This will be fixed in the next Excel package release - which will definitely be this month. I’ll keep you posted so you will know when to update the package.

ID: 6230


Program issue when on Orchestrator
#13

Aaaand, it’s out: