Copy to clipboard not working in background

Hi there,

I want to use type activities that have to run in the background. The problem is that when I use simulate type, the first round bracket is never typed. When I use send window messages, the special alt characters like umlaut are transformed into other letters: ü turns into y for example. So I tried copy to clipboard and send hotkey. But when running in the background: the set to clipboard activity gives errors, please find screenshot below. I have updated uipath system and activities to the latest versions: 20.10. And I’ve tested the issues in: Chrome, internet explorer and notepad ++.

Thanks a lot for helping out here!

hey @Emillie_Peeters

check once if this helps: Clipboard Activities In UiPath - YouTube

@Emillie_Peeters Have you tried keeping a delay before typing in background?
It might be possible that the page has not loaded completely and type into started its work.
Simulate click ideally works in the background case.

Let me know your findings.

wait

Dear Doshi,

Thanks for your feedback.

I need to get a variable coming from a databse to the clipboard in the background. When I use set to clipboardI received the error mentioned in the screenshot above when the pc got locked. I’m not sure how get selected text could help me with the data from the database.