Control not returning to main workflow after calling launch interactive workflow


#1

Hi all,
I am trying to call a separate session workflow using launch interactive workflow or invoke workflow file with isolated.
File gets called properly but control doesn’t return to main workflow and bot execution gets stuck there. I am returning a dictionary of datatable from launch interactive workflow to my main workflow


#2

You control may just be stopping somewhere within the workflow that you invoked. Make sure that there are no issues within the workflow that you are invoked. Try to debug and run it independently and see it it gets completed. Notice the error that is being thrown when the timeout happens. If your Main is a flow chart make sure that its connected properly to continue the execution flow.

Thanks,
Rammohan B.


#3

@Rammohan91 Independently its running fine . its clear by logs also its completing the execution , return data is very huge (4 data tables each with more than 50k rows in dictionary) , could it be that issue ?


#4

@Rammohan91 suggested for debugging do it properly from Main file.
or try to use some delays in other file that you’re invoking.

Cheers,
Pankaj


#5

Already done that but still not able to resolve it , i need total 8 such datatables in dictionary, if I run normally bot gets crashed after creating 4th datatable so I tried doing it in separate activity with isolated invoke workflow but datatable is not returning and bot keeps executing and giving error(attached in screen shot ) while stopping it forcefully after waiting for more than 10 mins


#6

Hello,

Make sure that your 4th datatable does not have empty/blank rows. if there’re these kind of rows please delete them and rerun and let’s know.

Cheers,
Pankaj


#7

Thanks I’ll give it a try


#8

I tried removing blank row, but still same error (used this code to remove blank rows : datatable.Rows.Cast(Of DataRow)().Where(Function(row) Not row.ItemArray.All(Function(field) field Is DBNull.Value Or field.Equals(""))).CopyToDataTable())


#9

@Pankaj.Patil and @Rammohan91 Main problem is serialization as datatable is not serializable and launch interactive workflow creates a separate bot process, hence it’s not being passed from one process to another. I have found the problem but not the solution. Perhaps this link will explain my problem
Passing Datatable using Launch Interactive workflow