Connected to Orchestrator but Uipath assistant is unable to retrieve license


I just changed my computer’s password to log in and now I’m not connected to the robot in Studio. I tried looking in Services to see if I can restart it, but Uipath is not listed. I’ve tried signing in and out, didn’t work.

When I go to Orchestrator it says I’m connected. I don’t know how to fix this and I can’t run anything in Studio without being connected to the robot.

Hello @elisa.sacchetti

So open Services in your machine

Se whether the Uipath Robot is in running state if not right click on that and refresh

Or you can check whether any service is in running in the task manager-> Details

if not go to this path and double click on the RobotJs.userhost and robotjs.servicehost and try again


C:\Users\Your user name\AppData\Local\Programs\UiPath\Studio

Hello, @elisa.sacchetti

Welcome to UiPath community!

Please try the steps in the below link

Open a cmd.exe console from Start and run this command and provide the screenshot:

sc query "UiRobotSvc" | find /i "failed" 2>&1>nul && echo.'Ui Robot service is not installed' || (sc query "UiRobotSvc"| find /i "running" 2>&1>nul && echo.Yes || echo.No)

Also, check this Testing licence robot status disconnected - #10 by marian.platonov

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.