Conflict between ORC 2019.10.14 and microsoft monitoring agent

I have upgrade orc to 2019.10.14
After windows patches the other day our orchestrator failed to start.

I found a potential conflict between Microsoft monitoring agent.
Does anyone have any experience in setting up 2019.10.14 with monitoring agent ?

We had the same problem. In the browser we got the 503: Service unavailable. The issue is also known at Uipath. Delete the Monitoring Agent from “Programs and Features / Uninstall programm”, reboot the complete server after that. Restart the IIS application (site) and the Dasbhoard should work again.

After that Microsoft Monitoring agent can be installed again.

1 Like

We found out that it crashed again after installing the MS Monitoring Agent again.This is a Microsoft Issue which let the Application pool crash, because it “thinks” it’s running on a old .NET version, which isn’t the case.
The problem occurs after .NET updates. The issue is known on 2012 servers, but also on 2016 servers with SCOM Microsoft Monitoring Agent installed. So far i could find there is no fix (the pathes won’t work), otherwise then disabling the APM

For example:
!! Ask your IT department to do this !!. Below is just an example. The main thing is that the MS Agent can be present, but APM should be disabled.

Stop IIS site
run the MS Agent installer with the extra parameters: NOAPM=1
#this will only delete the APM monitoring
msiexe.exec /fvomus “MsMonitoringAgent.msi” NOAPM=1

and disable serverSide APM monitoring

Make sure to ask your IT Department that they can disable APM monitoring.
Restart the server and IIS after that, to make sure that after a reboot APM is not enabled anymore

You can still use the monitoring agent, but make sure to disable APM monitoring. So far we haven’t run into 503 errors anymore.

1 Like

The problem occurs after .NET updates 4.7 , ORC need this version.
we disable APM , seems to have worked. let see during the next week

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.