Config File Taking Old File Path

Hi All,

I have changed my project name by modifying the name in Json file and also changed the config path and I have updated the new path but by default when the program runs it throws error in read range workbook.Everytime its picking the old path even I have updated the new path in Arguments panel.

image
It picks the old file path when I ran in debug mode.
image
My new Path is


@marina.dutta

you would have updated the value in the arguments of the xaml…

but in the import arguments where it is being called might be using the old path…please check the same

cheers

@marina.dutta

  1. Check Argument Values: Double-check that you have correctly passed the updated config path as an argument to the workflow. Ensure that the argument name matches the one in the JSON file. Also, verify that you are passing the correct path when invoking the workflow.
  2. Restart UiPath Studio: Sometimes, UiPath Studio caches project settings and arguments. Restarting UiPath Studio can help ensure that the latest changes in the JSON file and arguments are taken into account.

Hi @marina.dutta

Try with closing,re open the project and run again

Hope it helps!!

Hi @marina.dutta

If you are created any variable to store the Config file path. Check the variable panels any default value is stored.

If stored then remove the default value in the variables panel.

If it’s not the case, then change the file to another folder and give the path of it.

Hope it helps!!

@Anil_G

Yes that was the cause .In import Arguments it was still old path. I have updated now and saved it.

1 Like

@marina.dutta - Can you check the Project Settings and see if the new project name is reflected in the field?

image

image

And when you go this Invoke workflow for InitAllSettings, does it show your current config path?

If not, update these two areas and let me know if it works.

Thanks!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.